Issues with Elastic Email Addon
Incident Report for Cloudways
Resolved
The intermittent issue with Elastic Email has been resolved. Any inconvenience that might have been caused is deeply regretted. Please feel free to contact our support if you need any further assistance.
Posted May 28, 2020 - 21:31 CEST
Identified
We are observing an intermittent issue with Elastic Email, due to which their email delivery is temporarily affected. We are in coordination with Elastic Email and they are actively pursuing to resolve the issue asap.
Any inconvenience that might be caused is deeply regretted.
Posted May 28, 2020 - 18:27 CEST