Issue with Amazon Web Services Infrastructure Provider [AWS Identity and Access Management administration]
Incident Report for Cloudways
Resolved
This issue has now been resolved and server creation/cloning functionality has been restored.

If you face any issue, please contact our Live Chat support.
Posted 7 months ago. May 04, 2017 - 01:35 CEST
Identified
We have detected a connectivity issue with Amazon, that leads to operations failing in creating new servers.

They are experiencing error rates and latencies on IAM administrative APIs (https://status.aws.amazon.com/) and their engineers are actively working to resolve the issue.

We will update as soon as we have an additional information here.
Posted 7 months ago. May 03, 2017 - 23:22 CEST