We have not observed any issues since our last update, and all websites remain fully operational. Upon investigation, we found that the websites entered an idle state due to the health checking mechanism of our infrastructure provider, Google Cloud Platform. This incident originated on their end, and we are actively working on mitigation plans to prevent such occurrences in the future. We sincerely apologize for the inconvenience caused and truly appreciate your continued trust and patience.
Posted Aug 01, 2025 - 07:24 UTC
Monitoring
All websites are now fully operational. Our team continues to investigate the root cause and will keep you informed of any developments.
We sincerely apologize for the service disruption and appreciate your patience while we worked to resolve the issue.
Posted Jul 31, 2025 - 14:56 UTC
Investigating
We are currently experiencing an issue with some applications in the US region. Our engineering team is actively working to identify and resolve the issue. During this time, users may experience difficulties accessing their websites.
We apologize for the inconvenience and appreciate your patience as we work to restore normal operations. We will provide updates as soon as we have additional information.