Maintenance - Partial Outage in Rackspace Hosted Email
Incident Report for Cloudways
Resolved
The intermittent issue with Rackspace has been resolved. Any inconvenience that might have been caused is deeply regretted. Please feel free to contact our support if you need any further assistance
Posted May 31, 2020 - 12:50 CEST
Identified
Our 3rd party email addon provider Rackspace will be conducting a scheduled maintenance activity today from 6pm CEST to 8pm CEST on their email hosted environment to enhance the stability in their environment.
Any inconvenience faced is highly regretted during the mentioned period.
For more details status.apps.rackspace.com
Posted May 30, 2020 - 17:27 CEST