Let's Encrypt New Installation
Incident Report for Cloudways
Resolved
Network update has been completed. This issue has now been resolved.
If issue persist then please contact our support for assistance.

Cloudways Team
Posted about 1 year ago. Jul 28, 2016 - 10:46 CEST
Update
It has been fixed in latest version of Letsencrypt client, we are now rolling out this update on existing network, which will be completed in next few hours.
Posted about 1 year ago. Jul 28, 2016 - 09:58 CEST
Identified
Let's Encrypt SSL Authority is facing issues when installing. Therefore new installations for Let's Encrypt SSL will not be available.
Current running SSL will not be affected. We will further update once we have got more information.
Posted about 1 year ago. Jul 27, 2016 - 18:27 CEST