Rackspace portal accessibility issues for support team members
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 17:35 UTC
Identified
We are currently experiencing a technical issue that is preventing our support team from accessing the Rackspace email service to provide assistance, although Rackspace's email service remains operational for users.

Our backend team is actively investigating the issue and collaborating closely with Rackspace to address the situation promptly. We will provide updates on the issue as soon as possible. The inconvenience caused to our customers is highly regretted.
Posted Mar 18, 2024 - 10:54 UTC
This incident affected: Add-on Services (Rackspace Email).