Issue Adding Servers on DigitalOcean

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 01:33 UTC

Investigating

We are encountering difficulties adding servers at DigitalOcean in several regions. Our team is collaborating closely with the DigitalOcean support team to address the issue and will provide updates on this page as soon as new information is available. We sincerely apologize for the inconvenience.
Posted Oct 22, 2025 - 23:36 UTC
This incident affected: Cloud Providers (DigitalOcean).