Issue with Rackspace POP, IMAP and Webmail Services
Incident Report for Cloudways
Resolved
Rackspace issue has been resolved now. Any inconvenience that might have been caused is deeply regretted. Please feel free to contact our support if you need any further assistance.
Posted 22 days ago. Jun 27, 2019 - 01:39 CEST
Identified
Rackspace is having disruption with their Hosted Email services. Users will experience slowness when accessing their email. This includes slowness accessing Webmail, loading messages, attachments, and connecting using IMAP and POP3.
Posted 23 days ago. Jun 26, 2019 - 22:27 CEST