Rackspace - Partial Outage in Hosted Email Services
Incident Report for Cloudways
Resolved
This incident has now been resolved and Rackspace Hosted Email platform is now operating as normal.
Posted Jun 04, 2020 - 10:17 CEST
Investigating
Our email addon provider Rackspace is investigating an issue that is affecting our Hosted Email environment. We will post more details as soon as they become available.
Posted Jun 04, 2020 - 09:32 CEST