Issues with Elastic Email addon
Incident Report for Cloudways
Resolved
The issue with the Elastic Email addon has been resolved now. Any inconvenience that might have been caused is deeply regretted. Please feel free to contact our support if you need any further assistance.
Posted May 04, 2020 - 00:10 CEST
Identified
We have observed an issue on our Elastic Email addon due to which email delivery has been affected. Our team is working to resolve on urgent basis.

Any inconvenience that might be caused is deeply regretted.
Posted May 03, 2020 - 23:01 CEST