Lets Encrypt Installation Faliure due to downtime of acme endpoints

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Nov 01, 2024 - 03:33 UTC

Identified

As per the latest updates from Let's Encrypt, the issue has been identified and the infrastructure problem preventing domain name validation has been resolved, and issuance of certificates is recovering.
Posted Nov 01, 2024 - 01:52 UTC

Investigating

We have received a few reports of installation failure of SSL due to Lets encrypts acme-challenges endpoint being down as reported on https://letsencrypt.status.io/pages/55957a99e800baa4470002da

Our team is actively investigating the issue and will provide updates as soon as we have more information.
Posted Nov 01, 2024 - 01:46 UTC