Issue with Digital Ocean Infrastructure Provider
Incident Report for Cloudways
Resolved
All issues have been resolved at this time and all services / operations are working fine now. Please feel free to contact our support in case you need any assistance.

Cloudways Team
Posted 7 months ago. Apr 14, 2017 - 19:54 CEST
Monitoring
Although Digital Ocean has not yet updated their status page, all processes seem to be working now. While we wait for them to acknowledge full recovery, all Digital Ocean related activities on our platform should be available.

Once they update their status page, we will close this incident.

Cloudways Team
Posted 7 months ago. Apr 14, 2017 - 13:59 CEST