Issues with Rackspace Webmail
Incident Report for Cloudways
Resolved
We would like to inform you that the Rackspace Webmail issue has been resolved now and users can log into Webmail as expected. Any inconvenience that might have been caused is deeply regretted. Please feel free to contact our support if you need any further assistance.

Cloudways Team
Posted about 1 month ago. Aug 26, 2018 - 06:55 CEST
Identified
We are sorry for the inconvenience that you are facing with the Rackspace Webmail. We would like to confirm that we are continuously in contact with the Rackspace team and we will update as soon as we secure any successful response from them on the issue.
Posted about 1 month ago. Aug 24, 2018 - 18:13 CEST