Issue in launching New Servers
Incident Report for Cloudways
Resolved
The Subjected incident has been resolved. Any inconvenience that might have been caused is deeply regretted. Please feel free to contact our support if you need any further assistance.
Posted May 21, 2020 - 22:44 CEST
Investigating
Our Backend teams are working on an identified issue due to which "new server launch" function has been disabled for a short period of time, any inconvenience caused is highly regretted.
Posted May 21, 2020 - 18:06 CEST
This incident affected: Cloudways Cloud Platform Service.