VULTR - London - United Kingdom | Partial Outage
Incident Report for Cloudways
Resolved
The issue with the outage in the London region at Vultr has been resolved. We apologize for any inconvenience caused.
Posted May 19, 2020 - 09:21 CEST
Investigating
There is a partial outage in the VULTR London - United Kingdom region. You may face outage in a specified region. The Vultr team is currently investigating this issue. Your patience is highly appreciated.
Posted May 18, 2020 - 15:41 CEST