Let's Encrypt Planned Maintenance
Incident Report for Cloudways
Resolved
Let's Encrypt planned maintenance has been completed. Service is restored and should be working fine now. We apologize for any inconvenience you may have faced.
Posted Dec 05, 2019 - 07:35 UTC
Identified
Let's Encrypt will be performing production maintenance. This may effect installation or renewal of your SSL certificate on Cloudways platform.

December 4th 17:45 to 18:25 UTC.
December 5th 17:00 to 17:40 UTC.

Any inconvenience that might be caused is deeply regretted.
Posted Dec 04, 2019 - 18:25 UTC