Issues with Live Chat
Incident Report for Cloudways
Resolved
The intermittent issues over our LIVE CHAT has been resolved. Any inconvenience that might have been caused is deeply regretted. Please feel free to contact our support if you need any further assistance
Posted Apr 02, 2020 - 20:28 CEST
Investigating
We are experiencing intermittent issues over our LIVE CHAT, issue is being identified and being looked upon, our ticketing system is operational as usual.
Posted Apr 02, 2020 - 19:57 CEST