DNS resolution errors with Amazon Route 53
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 06:30 CEST
Update
DNS resolution errors with Amazon Route 53 has been resolved.

In case of any questions, feel free to reach out our support.
Posted Oct 23, 2019 - 06:30 CEST
Identified
We have observed some DNS resolution errors with Amazon Route 53, on which they are working to resolve the issues. Meanwhile, addition, restoration and backup operations of servers/applications would be affected. We would update the status once we have an update from AWS team. Any inconvenience that might have been caused is deeply regretted.
Posted Oct 22, 2019 - 21:52 CEST
This incident affected: Cloudways Cloud Platform Console.