Issue with Digital Ocean Infrastructure Provider
Incident Report for Cloudways
Resolved
All issues have been resolved at this time and all services / operations are working fine now. Please feel free to contact our support in case you need any assistance.

Cloudways Team
Posted 6 months ago. Apr 05, 2017 - 23:49 CEST
Investigating
DigitalOcean is reporting connectivity issues to their API. For Cloudways customers this means console operations related to DigitalOcean (launch new servers or any operation on existing ones will not work). Existing sites on already launched DigitalOcean servers should continue to operate normally.

We are in touch with DigitalOcean engineers and following up the resolution path. We will keep posting updates as we get them or you can follow up through DigitalOcean status page: https://status.digitalocean.com/

Cloudways Team
Posted 6 months ago. Apr 05, 2017 - 17:56 CEST