VULTR Seattle - United States | Outage / Maintenance
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Dec 14, 2019 - 18:57 CET
Identified
An outage or maintenance window is affecting a subset of users in this region.

Vultr team is further investigating the issue at this point in time. We would update once we get more information about this.

Any inconvenience that might be caused is deeply regretted.
Posted Dec 14, 2019 - 16:50 CET