Issue with Backup || Digital Ocean servers
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted May 20, 2021 - 07:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Please contact Cloudways Support in case you have any issues.
Any inconvenience caused is deeply regretted.
Posted May 19, 2021 - 12:31 UTC
Identified
We have identified an issue with our backup operations on the Digital Ocean London region which is related to the DNS and our engineering team is working on it. We sincerely apologize for any inconvenience caused in this regard.
Posted May 19, 2021 - 08:02 UTC