Elastic Email Issue
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Apr 15, 2022 - 00:29 UTC
Investigating
We are currently observing issues in email delivery on Elastic email. Our team is coordinating with Elastic email team to resolve the issue. Customer might faced delay in email delivery during this time. We regret for the inconvenience caused to you in this regard.
Posted Apr 14, 2022 - 14:10 UTC
This incident affected: Cloudways Cloud Platform Service.