Digital Ocean(DO) Servers not available for new server provisioning
Incident Report for Cloudways
Resolved
DO servers can be launched now from Cloudways Platform without any issue, any inconvenience caused is highly regretted.
Posted Oct 01, 2020 - 19:35 UTC
Investigating
We are in coordination with DO for the resolution, inconvenience caused is deeply regretted.
Posted Oct 01, 2020 - 18:09 UTC