Elastic Email Domain Validation Issue
Incident Report for Cloudways
Resolved
Please note the latest update regarding Elastic email domain validation requirement:

Customers who subscribed to Elastic Email Add-on before the 1st of October, 2021 will have the Domain Validation on hold for now so they may validate their domain in the coming days.
Posted Nov 25, 2021 - 14:48 UTC
Identified
We have investigated the problem that some of our customers are facing with Elastic Email. In particular, there are two things to consider:

1. Due to missing domain validation, emails are bouncing. We’d recommend that users affected by this take out the time to fully validate their domains from our platform. Please go through our KB for more details on this.

2. Domain verification failing on our platform. If this is happening for you, please reach out to our support team and they will help you in manually adding the domain and verifying it on Elastic Email.
Posted Nov 17, 2021 - 08:55 UTC
Update
We are continuing to investigate this issue.
Posted Nov 17, 2021 - 02:53 UTC
Investigating
We are currently investigating an issue with our Elastic Email addon related to domain validations. Email messages generated by some applications might fail to deliver because of this. Our engineering team is closely working with our vendor to resolve this incident as soon as possible.
Posted Nov 17, 2021 - 02:51 UTC