Issue with Domain Update Feature
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 00:31 UTC
Investigating
Our engineering team has observed an issue regarding Domain update feature on our platform where the domain update operation is taking more than expected time to complete. We are working to resolve this issue on priority and sincerely apologize for any inconvenience caused in this regard.
Posted Jun 20, 2022 - 13:48 UTC
This incident affected: Cloudways Cloud Platform Service.