Slow Platform Operations
Incident Report for Cloudways
Resolved
This incident has been resolved completely, any inconvenience caused is deeply regretted.
Posted Oct 15, 2020 - 12:44 UTC
Monitoring
The issue has been resolved, and platform operations are completing as per expectation, we are monitoring the operations closely. Thanks for your understanding in this regard.
Posted Oct 15, 2020 - 09:05 UTC
Identified
We are currently investigating an issue that has rendered our Cloudways Platform(https://platform.cloudways.com) to be slow in completing in-progress operations.

Our teams are actively working for the resolution, any inconvenience caused is highly regretted.
Cloudways Team
Posted Oct 15, 2020 - 07:49 UTC
This incident affected: Cloudways Cloud Platform Console.