Vultr - Seattle | Partial Outage
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Aug 21, 2020 - 07:04 UTC
Investigating
We are currently experiencing a partial outage in Vultr's Seattle location. Vultr's network engineers are actively working with their upstream provider to restore connectivity as soon as possible.
Posted Aug 20, 2020 - 14:37 UTC