Elastic Email | Email Delays

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 17:21 UTC

Monitoring

The Elastic Email team has applied a fix, and email deliverability performance is returning to expected levels. We are in close coordination with the Elastic Email team to ensure the issue is fully resolved. Our team will continue monitoring until stability is confirmed.
Posted Aug 29, 2025 - 13:38 UTC

Update

We are continuing to investigate this issue.
Posted Aug 29, 2025 - 08:18 UTC

Investigating

We are actively investigating an issue with the Elastic Email service that is causing an inconvenience. We sincerely apologize for any disruption and are working closely with Elastic Email to resolve this as quickly as possible
Posted Aug 29, 2025 - 08:18 UTC
This incident affected: Add-on Services (Elastic Email).