The issue has been resolved. Please contact our support if you continue to experience any related issues.
Posted Jul 01, 2026 - 09:35 UTC
Monitoring
We are seeing positive signs of recovery following the storage malfunction in the USSC Region. The majority of applications have resumed normal operation and services are largely restored. Our team continues to closely monitor the situation to ensure full stability.
We will provide a further update once we have confirmed complete resolution. We appreciate your patience throughout this incident.
Posted Jun 30, 2026 - 15:53 UTC
Investigating
We are currently experiencing an infrastructure issue caused by a storage malfunction in USSC Region. This may result in degraded performance or service disruptions for some users. Our team is actively investigating and working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologize for the inconvenience.