Latency Issue on chat support
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 09:33 UTC
Identified
We're currently observing latency issues with our chat system. This incident has already been reported to their support team, who are actively addressing the matter. We'll keep you informed as we receive further updates from them.

Once again we apologize for the inconvenience caused.
Posted Aug 17, 2023 - 08:22 UTC
This incident affected: Cloudways Support.