Cloudways Platform | Login/2FA issues

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jun 15, 2025 - 13:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 15, 2025 - 11:57 UTC

Investigating

We are currently experiencing 2FA issues on our platform. Our team is actively looking into the root cause and working to restore normal functionality as soon as possible. Please be assured that this is only causing login/access issues to our platform and that your servers and applications are unaffected. We sincerely apologize for any inconvenience this may cause.
Posted Jun 15, 2025 - 09:55 UTC
This incident affected: Cloudways Cloud Platform Service.