Issue with Rackspace Email Addon

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 13:33 UTC

Identified

We are experiencing issues when adding or deleting Rackspace mailboxes, or updating mailbox passwords, through our Platform. This is resulting in errors for affected users.

We are working with the Rackspace team to resolve this issue and will update you as soon as possible. We apologize for any inconvenience caused.
Posted Jul 16, 2026 - 20:57 UTC
This incident affected: Add-on Services (Rackspace Email).