Live Chat support slowness and lagging response

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted May 18, 2023 - 10:48 UTC

Investigating

We are experiencing slow response time and lagging on our live chat support system, we are coordinating with our provider for this issue. Inconvenience caused to our customers is highly regretted.
Posted May 15, 2023 - 10:46 UTC
This incident affected: Cloudways Support.