Elastic Email Service Interruption
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 07:42 UTC
Investigating
We are currently experiencing issues with the Elastic Email service, and we are investigating the cause of the disruption. Our Engineering team is working closely with Elastic Email support, who are aware of the problem and are actively investigating. We will share additional updates once we have more information from Elastic Email.

Please accept our sincere apologies for any inconvenience caused because of this issue.
Posted Oct 15, 2024 - 16:45 UTC
This incident affected: Add-on Services (Elastic Email).