Cloudways Platform | Slow Platform Operations

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 13:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2025 - 11:25 UTC

Investigating

We are currently experiencing performance issues that are affecting the operations of our platform. Our team is actively investigating the root cause of these slow operations to restore normal functionality as soon as possible.
Posted Apr 09, 2025 - 09:06 UTC
This incident affected: Cloudways Cloud Platform Console and Cloudways Cloud Platform Service.