Phone Number Verification Issue
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jul 21, 2024 - 04:17 UTC
Identified
We're currently experiencing a temporary technical issue that is preventing users from verifying their phone numbers. Our team is actively working on a resolution, and we expect to have this fixed as soon as possible. We apologize for any inconvenience this may cause.
Posted Jul 21, 2024 - 03:54 UTC
This incident affected: Cloudways Cloud Platform Console.