Rackspace - Webmail Access and Email Delivery Delays

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 16:16 UTC

Investigating

Rackspace is currently facing issues with accessing webmail along with minor delays in email delivery. Their engineering team is actively investigating the issue to restore full functionality as quickly as possible.

We will continue to provide updates as more information becomes available. Thank you for your patience and understanding.
Posted Sep 11, 2025 - 17:10 UTC
This incident affected: Add-on Services (Rackspace Email).