DigitalOcean Global Outage
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 02:56 UTC
Investigating
DigitalOcean is currently experiencing a global outage. Our Engineering team is in communication with DigitalOcean's team to resolve this issue as soon as possible. Any inconvenience is highly regretted.
Posted Jun 14, 2022 - 00:06 UTC