Rackspace Mail box creation issue

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jan 24, 2023 - 20:53 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 24, 2023 - 19:27 UTC

Investigating

We have identified an issue with mailbox provisioning on our Rackspace Addon. Our Engineering team is currently coordinating with Rackspace support team. However existing mailboxes are working as expected. Any inconvenience caused in this regard is highly regretted.
Posted Jan 24, 2023 - 11:25 UTC
This incident affected: Add-on Services (Rackspace Email).