Elastic email connectivity issue

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:04 UTC

Monitoring

The issue has been identified and a fix has been implemented. We are continuing to monitor the service to ensure stability.
Posted Oct 20, 2025 - 03:13 UTC

Investigating

We’re currently experiencing connectivity issues with Elastic Email, which are affecting email sending and domain verification. Our team is actively working with the Elastic Email support team to resolve the problem as quickly as possible. We’ll keep you updated with any progress. We apologize for the inconvenience and appreciate your patience while we work on this.
Posted Oct 19, 2025 - 10:18 UTC
This incident affected: Add-on Services (Elastic Email).