Racksapace Addon Issue
Incident Report for Cloudways
Resolved
The issue with our Rackspace email addon service has been resolved, inconvenience caused for creating new mailboxes is deeply regretted.
Posted Jan 20, 2021 - 00:11 UTC
Identified
We are getting an issue with our Rackspace email addon service due to which our customers are not able to create new mailboxes however existing mailboxes are working as expected. Our Engineering team is coordinating with their support and hope to resolve it very soon. Any inconvenience caused in this regard is highly regretted.
Posted Jan 19, 2021 - 22:11 UTC