Email Delivery Latency Affecting Login Verification

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 10:01 UTC

Investigating

We are currently investigating an issue where users are experiencing significant delays in receiving two-factor authentication (2FA) codes via email.

This issue has been traced to a service degradation with one of our upstream email delivery providers. We are in contact with their support team to monitor their progress on a fix. We apologize for the delay and will provide an update as soon as the provider shares more information.
Posted Jan 19, 2026 - 09:12 UTC