Lets Encrypt DST Root CA X3 Expiration
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Oct 03, 2021 - 11:58 UTC
Monitoring
Our Engineering team investigated the issue extensively and observed that there are two scenarios related to this issue as stated below:

1) cURL, or any other server-specific client http/ssl tool, breaking on SSL verification. We have identified and applied the fix for this issue. We are further monitoring the stability of fix applied and shall keep our customers posted upon this.

2) Old web browsers, on mobiles and desktops, unable to load websites because of the expired certificate in their local trust chains. This should have been a very small subset of users, involving users running old versions of OS on their phones and machines. There is no fix for this other then to update the OS on their laptops, mobiles and machines. The other option in this case is to switch your SSL to some other SSL certificate provider.
Posted Oct 01, 2021 - 18:28 UTC
Investigating
There has been a change in the Let's Encrypt's root certificate, which will cause the SSL error. You can read about that here:
https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/

The change shouldn't affect all browsers, it should work on newer browsers/devices, but it seems it affects some others. Our Engineering team is closely reviewing the change for a possible fix to minimise the impact (if possible).

Your patience in this issue is highly appreciated!
Posted Sep 30, 2021 - 16:04 UTC
This incident affected: Cloudways Cloud Platform Service.