Accessibility issues with Rackspace webmail portal
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jan 21, 2023 - 10:59 UTC
Monitoring
The network connectivity issues from Rackspace have been resolved. The non-impactful stage of the planned maintenance continues. Mailboxes should now be accessible, however some may experience performance degradation while we continue to validate all services.
Posted Jan 20, 2023 - 05:49 UTC
Update
We are continuing to investigate this issue.
Posted Jan 20, 2023 - 03:41 UTC
Investigating
We are receiving a number of complaints related to customers not able to login to their Rackspace mailbox via webmail portal or using any third party email clients. The issue has been identified by the Rackspace team and they are working on fixing the issue. We will update our status page as soon as we hear update from Rackspace team. Any inconvenience caused because of this issue is highly regretted.
Posted Jan 20, 2023 - 03:39 UTC
This incident affected: Add-on Services (Rackspace Email).