Slow Platform Operations
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 18:47 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 01, 2023 - 10:24 UTC
Identified
We have identified slow response from our backend for the operations to complete which are triggered from the Platform UI. Our engineering team is investigating it further.

Please feel free to contact our 24*7 support team if you need any assistance from our side. Any inconvenience caused because of this issue is highly regretted.
Posted Jun 01, 2023 - 10:14 UTC
This incident affected: Cloudways Cloud Platform Console.