Cloudways Autonomous: Partial Service Degradation

Incident Report for Cloudways

Update

We are continuing to investigate this issue.
Posted Feb 12, 2026 - 14:48 UTC

Investigating

Some Cloudways Autonomous applications hosted in the London region may experience temporary connectivity issues due to a partial disruption in the underlying storage service. Our team is actively working with the infrastructure provider to restore full stability as quickly as possible.
Posted Feb 12, 2026 - 14:43 UTC
This incident affects: Cloudways Cloud Platform Console.