Rackspace Addon
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 10:24 UTC
Investigating
We are currently experiencing a service disruption. Our team is working to identify the root cause and implement a solution. Some users may be affected due to this disruption.

We will send an additional update as soon as possible.
Posted Jan 30, 2023 - 21:12 UTC
This incident affected: Add-on Services (Rackspace Email).