UI Navigation Issues on Staging Applications

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 19:06 UTC

Identified

We are currently experiencing issues with User Interface navigation on our staging applications. Our engineering team is actively investigating the matter and working to implement a resolution as quickly as possible.

We sincerely apologize for any inconvenience this may cause and appreciate your continued patience. We will share further updates as soon as more information becomes available.

As a temporary workaround, customers can use the PULL/PUSH functionality within Staging Management to sync updates from the Production application.
Posted Apr 16, 2025 - 21:53 UTC
This incident affected: Cloudways Cloud Platform Console.