Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 08, 2026 - 06:00 UTC
Scheduled
We will be conducting an important platform maintenance to deploy a new feature—Per-Application PHP Version Selection—during the following window:
Activity start time: 8th August, 06:00 UTC Activity end time: 8th August, 06:30 UTC
Impact Area during the activity:
Cloudways Platform will temporarily experience downtime. Server and application management operations may experience temporary slowness or brief service reloads during updates. We will promptly inform you as soon as this maintenance is completed. Thank you for your patience and understanding as we work to improve your experience. If you have any questions, please feel free to reach out to our support team.
Posted Aug 07, 2026 - 11:06 UTC
This scheduled maintenance affected: Cloudways Cloud Platform Console.