Verification is currently underway for the maintenance items.
Posted Nov 08, 2025 - 06:00 UTC
Update
Scheduled Maintenance has been completed now and the platform is operational now. We are monitoring it if there are any reported issues.
Posted Nov 08, 2025 - 05:59 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 08, 2025 - 05:00 UTC
Scheduled
We will be conducting an important platform maintenance to enhance performance and reliability during the following window:
Activity start time: 8th November, 05:00 UTC Activity end time: 8th November, 06:00 UTC
Impact Area during the activity: - Cloudways Platform will temporarily experience downtime. - Flexible product operations may experience temporary slowness. - There will be no impact on your site's overall availability.
We will promptly inform you as soon as this maintenance is complete. Thank you for your patience and understanding as we work to improve your experience. If you have any questions, please feel free to reach out to our support team.
Posted Nov 06, 2025 - 08:29 UTC
This scheduled maintenance affected: Cloudways Cloud Platform Console and Cloudways Cloud Platform Service.